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1 Getting started 
 

  

 

Download Installation 

 

After downloading the product from the VRcontext Web site; 
double click on the downloaded file to launch the installation. 

 Select the installation path where Walkinside installation needs 

to take place. The default path is c:\program 
files\vrcontext\Walkinside 5.x 

  

 

License 

 
Walkinside 5 uses FLEXNET

TM
 (a Macrovision® product) as 

license management system. 
Node locked licenses and concurrent network licenses are 

available, therefore VRcontext recommends placing this 

license in the VRcontext/Walkinside 5.x/VRLicense folder. 
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2 Walkinside Builder 
                 

              
 

The Walkinside Viewer expects all the information pertaining to a VR model to be included in a ñprojectò. 
 

A ñprojectò contains all the files and sub directories containing all the data and information required to 

visualize a VR model. In the example here above, see a ñprojectò, called equip and all the related files 
and sub directories. 

2.1 VRConversionStudio (standalone converter) 

 
The VRConversionStudio is a standalone application allowing the user to export CAD files from the CAD 

format directly to VRcontext proprietary format without the need of having the CAD software installed on 

the PC. 
 

To export a native model, the user must go through the following steps: 
 

Launching the VRConversionStudio application will open the following window. 
 

 
 

The first step is, as explained here above is to create a new ñprojectò, or open an existing one. 
 

The extension of a VR Builder Studio ñprojectò file is .vrbsp.  
 

The user will find under ñProjectò the following menu: New, Open, Save, Close and Exit. Under ñModelsò: 
Add and Remove, and under ñBuildò: Start. 

 

The meaning behind Open, Save, Close and Exit is quite self-explanatory. 
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When the user creates a new project, a project type selection window will pop up so the user can choose 

between a PDMS or a 3ds project, in case of selecting PDMS, pdms files will need to be chosen to 
complete the project, in case of 3ds, the files will need to be in 3d Studio file format.  

 
 

Once a project is active, the following window will appear. 
 

 
 

 
By clicking on ñModels->Addò or right-click on Project->Add, the user can browse through all the 

directories to select the CAD files he wants to include in the list of files to be converted. By keeping the 
<Shift> key down, a group of files can be selected. By keeping the <Ctrl> key pressed specific files can 

be appended to the selection. 
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Once all the desired files have been selected, the window will show the list of selected CAD files. The 
user should first do a ñsaveò. He must then go to ñBuildò, and click on Start. 

 
This will start the export process that will automatically convert the CAD files to VRcontext proprietary 

format.  
 

 
 

Important: The project must be saved before going into ñBuildò and click on Start. 
 

 
When the export is finished, a new folder is created bearing the same name as the vrbsp project file 

saved before. 

2.1.1 PDMS Export 

 
When the user converts a PDMS CAD file, more options are available to customize the look of the model. 

 
For instance, once a CAD file has been added in the export list, the ñMaterialsò, ñInformationò and 

ñDatabaseò buttons are active: 
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It is important to define the colors at Project startup. The "Materials" tab allows the user to modify the 
pre-defined color. With the generate colors button, the user lets the system allocate random colors. 

 
This selection of color has to be repeated as many times as needed for each file to be converted. Once 

this is done, the user can review the files included in the selected Project.  
 

If the user still wants to change the color, he simply has to double-click on the colored square and it will 
overwrite the existing color with the new selection. 

 

Once all the files have been added, simply ñsaveò. The user then goes to ñBuildò, and click on Start. 
 

This will start the process that will automatically convert the PDMS CAD files to VR.  
 

 
 
PDMS Database export 

 

The VRConversion Studio also supports PDMS database files (datal information) to be exported within 

the vr file. This export of the PDMS database is done automatically once the VRConversion Studio 
detects a datal file having the same name as the PDMS file to be exported with the extension selected in 

the ñDatabaseò button. 
  

The datal file is a text file containing the attributes of each element in the PDMS file. When this file is 
exported from the PDMS application, the user can choose any extension (.txt,.att,.datalé). Therefore the 

VRConversion Studio will read the user selected file extension for these database files. 
 

By default the database file extension is assumed to be .txt. The name of this extension can be modified 

with the ñDatabaseò button when a project is selected.  
 

 
 
 

A PDMS database file is supported for each PDMS file. 
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2.1.2 3DS Export 

 

To start a 3ds project, select 3ds on the project selection. 
 

 
 

After adding the needed files as explained above, the user has to choose the scale to use (3DS has no 

reference to any units in the file, they are global units), taking into account that when scale = 1 it wi ll 
export meters. 

 
 

After selecting the scale save the project and start the build. A new folder with the project name will be 
created in the same folder where the project is located. 

 

2.1.3 PDMS Batch converter 

 
When using VRconversionStudio, the export can be run through the command line or drag and dropping 

the project to the executable. 
 

The command to be used is: 
 

ñPath to the executable\VRconversionStudio.exeò ñPath to the project\project_name. vrbspò 

 
For example: 

"C:\program files\vrcontext\walkinside 5.3\VRConversionStudio.exe" "E:\models\VRcontext\WI 
5.3\stabilizertest.vrbsp" 

 
This type of export allows the user to schedule exports using the windows scheduler easily. 
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2.2 MicroStation (exporter plugin) . 

 

Beside the stand alone exporter outlined here above, the Walkinside Builder also exports files from 
MicroStation. The versions supported today are MicroStation V8 and MicroStation V8 XM. 

 
To export a file already open in MicroStation, just go to the Main Menu and select File->Export-> 

Walkinside 5. 

 
In the export process, a ñprojectò containing all the files and sub directories - containing all the data and 

information required to visualize a VR model ï will be created having as folder name, the name of the 
exported .dgn file. 

 

 
 
 

A new dialog will appear where the user will be able to select the View used during the export. 
 

 

 
 

At this point, if the file contains a PDS database, the user can decide to export this database or not. If the 

user selects the database option, a .dri file, having the same name as the .dgn file must exist in the same 
folder as the .dgn file being exported. 

 
To finish the export, just click on the OK button.  
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When the export is finished, a dialog box will appear showing some key parameters of the conversion 

process. 
 

 

 
 
 

When the conversion is completed, the new ñprojectò folder will be located in the same folder as the one 
containing the original dgn file. 

 
NOTE: Textures and transparencies are supported  
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2.3 MicroStation Batch Exporter. 

 

The user has also the possibility to do a batch conversion on a set of dgn files. This batch conversion, is 
executed using command lines. Therefore this will allow an export of several dgn files without having to 

be in front of the PC, using Windows Scheduler. 
 

There are 2 different types of commands that can be executed, depending on the type of conversion: 

 
 

MultiDGN conversion: 
 

This will export all the .dgn files listed in the .txt file (without their associated databases). One .dgn file 
must be written per line. In the export process, a ñprojectò containing all the files and sub directories will 

be created having as folder name, the same name as the .txt file and located in the same directory. 
 

A typical command line would like: 

 
ñC:\Program Files\Bentley\Program\MicroStation\ustation.exeò -WAwalkinside5.ma -ID:\Models\P-38\P-

38.txt 

 
where D:\Models\P-38\P-38.txt is the location of the input file. 

 

MultiDGN conversion with selected View: 
 

By default the View used in the export here above is the first one encountered when the dgn file is 

opened in MicroStation. If needed, the user has the opportunity to select another view, by adding one 
parameter to the above command line: 

 
ñC:\Program Files\Bentley\Program\MicroStation\ustation.exeò -WAwalkinside5.ma -ID:\Models\P-38\P-

38.txt,2 

 

Taking into account that the first View encountered in MicroStation will correspond to View 0, by selecting, 
View 2, the user has elected the second encountered View for the export. 
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2.4 PDS Batch conversion 

 

This will export all the dgn files listed in the .dri file (with their associated databases). In the export 
process, a ñprojectò containing all the files and sub directories will be created having as folder name, the 

name given before the export starts. 
 

 
 

- The first step is to select a DRI file. This is done by pressing the ñBrowseò button in the 

upper left part of the dialog. In the left list box, all the available dgn and prp files are 
displayed. 

- Select the files that need to be in the VR file, and press the ñAdd selectedò button. On 
the right list box, the files just selected should now be listed. 

- The right list box displays all the files that will be converted in one big VR file. It is still 

possible to remove files from the list by selecting them and pressing the ñRemoveò 
button. 

- Verify the Convert options if there are correctly set. Note: The MS Folder is the folder 
where Microstation executable is installed.  

- Press start and wait until the conversion is done. 
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2.5 XMpLant batch Converter (Optional module standalone) 

 

The XMpLant converter exports XMpLant files into the VRproject format. This module can only run in 
batch mode and the batch conversion is executed using the command line. Therefore this will allow an 

export without having to be working on the PC, using the Windows Scheduler. 
 

To run the exporter the user has to execute the XMpLantVrExporter.exe to be found in the 

Walkinside/Converter/XMpLant folder. 
 

The command line will include two parameters, the input file name and the output VRproject name. 
 

The name and location of the xml file to be converted is given as first parameter. In the export process, a 
ñprojectò containing all the files and sub directories will be created having as folder name and location, 

the second parameter. 
 

To facilitate the users work, Walkinside 5 includes an XMpLant.bat file that  allows the user to drag and 

drop an XMpLant file to it to have a direct conversion. The output file will be created by the XMpLant file.  
 
echo off 
if "%1"=="" goto USAGE 
cd /d %~dp0 
echo on 
XMpLantVrExporter.exe %1 %~dp1\%~n1 validate=false 
goto END 

 
:USAGE 
echo Drag and drop an xmplant on the batch file to start conversion. 
echo alternative launch XmPlantVrExporter.exe form command line. 
echo Usage: "XmPlantVrExporter <input filename> <output folder> validate=false" 
 

:END 
Pause 

 
The user can also run the conversion through the command line or using his own bat file. 

 

An example of the command could be: 
 

"C:\Program Files\VRcontext\Walkinside 5.x\converter\XMpLant\XMpLantVrExporter.exe"  
 ñG:\users\equip.xmlò    ñG:\users\equipò    validate=false 
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2.6 3DSMax (exporter plugin) 

 

In the installation package, the Walkinside Builder includes a plug-in allowing the user to export 3DSMax 
models into Walkinside. 

 
The supported 3DSMax versions are 3ds Max 7, 3ds Max 8 and 3ds Max 9, 3ds Max 2008 and 3ds Max 

2009. 

 
To export a file already opened in 3DSMax: 

1- Go to File->Export 
2- Choose the location to export Walkinside 5 file to be saved 

3- Select save as Walkinside 5(*.VRP) file format 
 

 
 

Select the needed options from the dialog box and click OK. 

 
 

 
 

Note: If the log export is switched ON the export would contain a lot of debug information but it 
will be very slow. 
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2.6.1 Export with textures with 3ds MAX 

 
In 3ds Max 9, 3ds Max 2008 and 3ds Max 2009 textures are supported. 

 

In order to export with textures the user needs to select Diffuse texturing in the ñMaterial Exportò option. 
If the user selects stream texturing streaming will be applied in the texture rendering while the model is 

not completely loaded. 
 

After the export is completed a small message appears with the export log information.  
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2.7 SolidWorks exporter ( Optional plug-in) 

In the installation package, the Walkinside Builder includes an optional plug-in allowing the export of 

SolidWorks models into Walkinside. 
 

The supported SolidWorks versions are SolidWorks 2007 and SolidWorks 2008. 
 

 

To have the Walkinside exporter icon            in the toolbar, the user must first load the plugin (Tools-
>Add-Ins and select Walkinside5) and then go to View-> Toolbar-> Walkinside5 and click. 

 

 
 

To export a model, the user just needs to: 
 

- Load the model loaded in the main SolidWorks window  
- Press the Walkinside5 icon.  

 
A new Walkinside ñprojectò containing all the files and sub directories will be created having as folder 

name, the same name as the SolidWorks model and located in the same directory.  
 

NOTE: Textures and transparencies are supported  
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2.8 AutoCAD (exporter plug-in) 

 

In the installation package, the Walkinside Builder includes a plug-in allowing the export of AutoCAD 
models into Walkinside. 

 
The supported AutoCAD versions are AutoCAD 2007, AutoCAD 2008 and AutoCAD 2009.  

 

To do the exports just follow the next steps: 
 

1- Load AutoCAD. 
2- Execute command ñnetloadò  

3- Load the appropriated walkinside5.dll from the Walkinside 5.x\converter\AutoCAD 200x folder 
4- Load the model to export 
5- Execute command ñWalkinside5ò 

6- Choose the units to export from and start the export. 

 

 
After the conversion is finished, a message with a resume of the export will pop up.  

 
 

 
 

 
The new model will be created in a folder with the same name and at the same location as the AutoCAD 

model exported. 
 

NOTE: There are other branches of AutoCAD that are also supported like AutoCAD Mechanical  
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2.9 AutoPlant Exporter 

 

AutoPLANT software is used for 3D Plant Modeling.  It is made up of 4 modules and these modules work 
on a single project methodology. AutoPLANT objects are custom developed graphics and linked with 

external Database. These objects / drawing files and info will not be properly displayed unless it is 
opened through the Document Manager Utility provided by the AutoPLANT software. 

 

2.9.1 Software Requirements: 

 
Following Basic softwares should be installed and opened and ñrun onceò before installing AutoPLANT 

to Walkinside Converter software. 
 

 AutoCAD2007 

 AutoPLANT XM (All required modules.  This software should be properly licensed) 

 Walkinside 5.3.0.17 or above 

 
 

 

2.9.2 Export a project 

 

1- Start AutoPlantExporter.exe from the Walkinside installation 
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2- Browse and select to the AutoPLANT project directory. In case, a non-AutoPLANT directory is 

selected, a warning message will appear. 
 

 
 

3- On selection of the valid AutoPLANT project folder, continue to Create/Select TARGET folder. 
 

 
 

4- After selecting the folder the following two dialogs will appear. 

 

 
 

 
 


